import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(AX|C)\\d+$";
final String string = "AX5\n"
+ "AX10\n"
+ "AX10asas\n"
+ "AX25\n"
+ "AX50\n"
+ "AX100\n"
+ "B25\n"
+ "B50\n"
+ "B100\n"
+ "B150\n"
+ "B200\n"
+ "C5\n"
+ "C10\n"
+ "C20\n"
+ "C50\n"
+ "C100\n"
+ "E5\n"
+ "E10\n"
+ "E25\n"
+ "CXX25\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}