const regex = /(AX|C)\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(AX|C)\\d+$', 'gm')
const str = `AX5
AX10
AX10asas
AX25
AX50
AX100
B25
B50
B100
B150
B200
C5
C10
C20
C50
C100
E5
E10
E25
CXX25
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}