$re = '/(AX|C)\d+$/m';
$str = 'AX5
AX10
AX10asas
AX25
AX50
AX100
B25
B50
B100
B150
B200
C5
C10
C20
C50
C100
E5
E10
E25
CXX25
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);