use strict;
my $str = 'este es un ejemplo•de Expr donde podemos ver claramente
que, ésta•seleccion Expr, pero no me selecciona expr
¿por •que•me selecciona "Expr" pero no•me•selecciona• "expr" ?';
my $regex = qr/Expr/mp;
my $subst = '<<reemplazar>>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";