using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9a-zA-Z]+(?:\s*,\s*[0-9a-zA-Z]+)*$";
string input = @"abc,def
abc, def
abc,def, &&778
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}