$re = '/^[0-9a-zA-Z]+(?:\s*,\s*[0-9a-zA-Z]+)*$/m';
$str = 'abc,def
abc, def
abc,def, &&778
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);