re = /^[0-9a-zA-Z]+(?:\s*,\s*[0-9a-zA-Z]+)*$/m
str = 'abc,def
abc, def
abc,def, &&778
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end