using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]+-[0-9]_([[:alnum:]]+_[0-9])[0-9a-zA-Z]+$";
string input = @"ECTB-3_ABC1192103_8G1D";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}