$re = '/^[a-zA-Z]+-[0-9]_([[:alnum:]]+_[0-9])[0-9a-zA-Z]+$/m';
$str = 'ECTB-3_ABC1192103_8G1D';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);