re = /^[a-zA-Z]+-[0-9]_([[:alnum:]]+_[0-9])[0-9a-zA-Z]+$/m
str = 'ECTB-3_ABC1192103_8G1D'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end