// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z]+-[0-9]_([[:alnum:]]+_[0-9])[0-9a-zA-Z]+$").unwrap();
let string = "ECTB-3_ABC1192103_8G1D";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}