# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?sx)
(?| # branch reset: both captures go to Group 1
\bblue\b(?=.*(bleu))
|
\bred\b(?=.*(rouge))
)/\1/gsx;t' <<< "blue cheese, a red nose.
bleu rouge"