import Foundation
let pattern = ##"""
(?sx)
(?| # branch reset: both captures go to Group 1
\bblue\b(?=.*(bleu))
|
\bred\b(?=.*(rouge))
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
blue cheese, a red nose.
bleu rouge
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)