package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(?sx)
(?| # branch reset: both captures go to Group 1
\bblue\b(?=.*(bleu))
|
\bred\b(?=.*(rouge))
)`)
var str = `blue cheese, a red nose.
bleu rouge`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}