using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sx)
(?| # branch reset: both captures go to Group 1
\bblue\b(?=.*(bleu))
|
\bred\b(?=.*(rouge))
)";
string substitution = @"\1";
string input = @"blue cheese, a red nose.
bleu rouge";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}