using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"("")?([^{:""]+)("")?(: )("")?([^,}""]+)("")?(, |}+)";
string substitution = @"""$2""$4""$6""$8";
string input = @"{location: ""Tel Aviv"", party_size: 2, date_time: 2023-05-06:09:00:00Z}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}