use strict;
my $str = '{location: "Tel Aviv", party_size: 2, date_time: 2023-05-06:09:00:00Z}';
my $regex = qr/(")?([^{:"]+)(")?(: )(")?([^,}"]+)(")?(, |}+)/p;
my $subst = '"$2"$4"$6"$8';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";