$re = '/(")?([^{:"]+)(")?(: )(")?([^,}"]+)(")?(, |}+)/';
$str = '{location: "Tel Aviv", party_size: 2, date_time: 2023-05-06:09:00:00Z}';
$subst = "\"$2\"$4\"$6\"$8";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;