using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w\K[^\s@]+@(\w)[^\s.@]+";
string substitution = @"*@$1***";
string input = @"testa@weste.de";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}