use strict;
my $str = 'testa@weste.de';
my $regex = qr/^\w\K[^\s@]+@(\w)[^\s.@]+/mp;
my $subst = '*@$1***';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";