$re = '/^\w\K[^\s@]+@(\w)[^\s.@]+/m';
$str = 'testa@weste.de';
$subst = "*@$1***";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;