re = /^\w\K[^\s@]+@(\w)[^\s.@]+/m
str = 'testa@weste.de'
subst = '*@$1***'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result