import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[uU](?=\\b|\\d)\\.?\\s*";
final String string = "Holics u 5/a\",\n"
+ " \"Holics U 5/a\",\n"
+ " \"Holics u5/a\",\n"
+ " \"Huolics u 5/a\",\n"
+ " \"Holics u. 5/a\",\n"
+ " \"Holuics u5\",\n"
+ " \"Holics and other stuff u more stuff after 5\",\n"
+ " \"Houlics utca 5";
final String subst = "utca ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}