import re
regex = re.compile(r"\b[uU](?=\b|\d)\.?\s*", flags=re.MULTILINE)
test_str = ("Holics u 5/a\",\n"
" \"Holics U 5/a\",\n"
" \"Holics u5/a\",\n"
" \"Huolics u 5/a\",\n"
" \"Holics u. 5/a\",\n"
" \"Holuics u5\",\n"
" \"Holics and other stuff u more stuff after 5\",\n"
" \"Houlics utca 5")
subst = "utca "
result = regex.sub(subst, test_str)
if result:
print(result)