# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i)(\s*)(|"|')(name|phoneNumber|race|gender|birthdate|geodata)(|"|')(\s*)(:|=)(\s*)('|"|\s*)(\s*)(^$|.*?)(\s*)('|,|"|\))/$1$2$3$4$5$6$7$8$9*******$11$12/gm;t' <<< "\"username\":\"username\"
\"phonenumber\":\"123 456 7890\"
\"race\":\"undisclosed\"
\"gender\":\"female\"
\"birthdate\":\"03/12/1889\"
\"geodata\":\"123 456 7890\"
\"phonenumber\":\"123 456 7890\"
\"geodata\":\"38.897957\""