// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?i)(\s*)(|"|')(name|phoneNumber|race|gender|birthdate|geodata)(|"|')(\s*)(:|=)(\s*)('|"|\s*)(\s*)(^$|.*?)(\s*)('|,|"|\))"#).unwrap();
let string = "\"username\":\"username\"
\"phonenumber\":\"123 456 7890\"
\"race\":\"undisclosed\"
\"gender\":\"female\"
\"birthdate\":\"03/12/1889\"
\"geodata\":\"123 456 7890\"
\"phonenumber\":\"123 456 7890\"
\"geodata\":\"38.897957\"";
let substitution = "$1$2$3$4$5$6$7$8$9*******$11$12";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}