import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(\\s*)(|\"|')(name|phoneNumber|race|gender|birthdate|geodata)(|\"|')(\\s*)(:|=)(\\s*)('|\"|\\s*)(\\s*)(^$|.*?)(\\s*)('|,|\"|\\))";
final String string = "\"username\":\"username\"\n"
+ "\"phonenumber\":\"123 456 7890\"\n"
+ "\"race\":\"undisclosed\"\n"
+ "\"gender\":\"female\"\n"
+ "\"birthdate\":\"03/12/1889\"\n"
+ "\"geodata\":\"123 456 7890\"\n"
+ "\"phonenumber\":\"123 456 7890\"\n"
+ "\"geodata\":\"38.897957\"";
final String subst = "$1$2$3$4$5$6$7$8$9*******$11$12";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}