# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^1\h+(?=\d)//gm;t' <<< "1 800-555-1111
1 222-555-1111
888-555-1111
1 888 555 1111
"