use strict;
my $str = '1 800-555-1111
1 222-555-1111
888-555-1111
1 888 555 1111
';
my $regex = qr/^1\h+(?=\d)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";