const regex = /^1\h+(?=\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^1\\h+(?=\\d)', 'gm')
const str = `1 800-555-1111
1 222-555-1111
888-555-1111
1 888 555 1111
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);