#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Caused\sby\:\s.+\.(?<ExceptionName>\w+Exception):"
Local $sString = "Caused by: javax.transaction.TransactionRolledbackException:" & @CRLF & _
"Caused by: com.gtnexus.database.exception.NoEntryAffectedException:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")