package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Caused\sby\:\s.+\.(?<ExceptionName>\w+Exception):`)
var str = `Caused by: javax.transaction.TransactionRolledbackException:
Caused by: com.gtnexus.database.exception.NoEntryAffectedException:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}