re = /Caused\sby\:\s.+\.(?<ExceptionName>\w+Exception):/m
str = 'Caused by: javax.transaction.TransactionRolledbackException:
Caused by: com.gtnexus.database.exception.NoEntryAffectedException:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end