$re = '/Caused\sby\:\s.+\.(?<ExceptionName>\w+Exception):/m';
$str = 'Caused by: javax.transaction.TransactionRolledbackException:
Caused by: com.gtnexus.database.exception.NoEntryAffectedException:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);