#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?imu)(?i)(?:https?:\/\/)?(?:www\.)?\K\S+\.\w{3}\/?[^\/\s,]+(?:[^\/]+)"
Local $sString = "http://autoitscript.com/blabla1/" & @CRLF & _
"http://autoitscript.com/blabla2/blabla/" & @CRLF & _
"http://autoitscript.com/bla-bla-bla3/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")