const regex = /(?i)(?:https?:\/\/)?(?:www\.)?\K\S+\.\w{3}\/?[^\/\s,]+(?:[^\/]+)/imu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?:https?:\\\/\\\/)?(?:www\\.)?\\K\\S+\\.\\w{3}\\\/?[^\\\/\\s,]+(?:[^\\\/]+)', 'imu')
const str = `http://autoitscript.com/blabla1/
http://autoitscript.com/blabla2/blabla/
http://autoitscript.com/bla-bla-bla3/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}