import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?:https?:\\/\\/)?(?:www\\.)?\\K\\S+\\.\\w{3}\\/?[^\\/\\s,]+(?:[^\\/]+)";
final String string = "http://autoitscript.com/blabla1/\n"
+ "http://autoitscript.com/blabla2/blabla/\n"
+ "http://autoitscript.com/bla-bla-bla3/";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}