using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:https?:\/\/)?(?:www\.)?\K\S+\.\w{3}\/?[^\/\s,]+(?:[^\/]+)";
string input = @"http://autoitscript.com/blabla1/
http://autoitscript.com/blabla2/blabla/
http://autoitscript.com/bla-bla-bla3/";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline | RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}