using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"url\((?!['""]?(?:data|http|https):)['""]?([^'""\)]*)['""]?\)";
string input = @"1. background: url(https://images/magnifier-ico.svg) no-repeat left center;
2. background: url(http://images/magnifier-ico.svg) no-repeat left center;
background: url('images/magnifier-ico.png') no-repeat left center;
background: url(""/images/magnifier-ico.svg"") no-repeat left center;
background: url(./images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}