re = /url\((?!['"]?(?:data|http|https):)['"]?([^'"\)]*)['"]?\)/i
str = '1. background: url(https://images/magnifier-ico.svg) no-repeat left center;
2. background: url(http://images/magnifier-ico.svg) no-repeat left center;
background: url(\'images/magnifier-ico.png\') no-repeat left center;
background: url("/images/magnifier-ico.svg") no-repeat left center;
background: url(./images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end