$re = '/url\((?![\'"]?(?:data|http|https):)[\'"]?([^\'"\)]*)[\'"]?\)/i';
$str = '1. background: url(https://images/magnifier-ico.svg) no-repeat left center;
2. background: url(http://images/magnifier-ico.svg) no-repeat left center;
background: url(\'images/magnifier-ico.png\') no-repeat left center;
background: url("/images/magnifier-ico.svg") no-repeat left center;
background: url(./images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;
background: url(../images/magnifier-ico.svg) no-repeat left center;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);