import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url\\((?!['\"]?(?:data|http|https):)['\"]?([^'\"\\)]*)['\"]?\\)";
final String string = "1. background: url(https://images/magnifier-ico.svg) no-repeat left center;\n"
+ "2. background: url(http://images/magnifier-ico.svg) no-repeat left center;\n"
+ "background: url('images/magnifier-ico.png') no-repeat left center;\n"
+ "background: url(\"/images/magnifier-ico.svg\") no-repeat left center;\n"
+ "background: url(./images/magnifier-ico.svg) no-repeat left center;\n"
+ "background: url(../images/magnifier-ico.svg) no-repeat left center;\n"
+ "background: url(../images/magnifier-ico.svg) no-repeat left center;\n"
+ "background: url(../images/magnifier-ico.svg) no-repeat left center;\n"
+ "background: url(../images/magnifier-ico.svg) no-repeat left center;";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}