#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!(^vlan6[0-9][0-9]\.199$))(^vlan6[0-9][0-9]\.[1-2][0-9][0-9]$)"
Local $sString = "vlan699.194" & @CRLF & _
"vlan699.199" & @CRLF & _
"vlan699.1993" & @CRLF & _
"vlan699.19" & @CRLF & _
"vlan699.200"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")