const regex = /(?!(^vlan6[0-9][0-9]\.199$))(^vlan6[0-9][0-9]\.[1-2][0-9][0-9]$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!(^vlan6[0-9][0-9]\\.199$))(^vlan6[0-9][0-9]\\.[1-2][0-9][0-9]$)', 'gm')
const str = `vlan699.194
vlan699.199
vlan699.1993
vlan699.19
vlan699.200`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}