import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!(^vlan6[0-9][0-9]\\.199$))(^vlan6[0-9][0-9]\\.[1-2][0-9][0-9]$)";
final String string = "vlan699.194\n"
+ "vlan699.199\n"
+ "vlan699.1993\n"
+ "vlan699.19\n"
+ "vlan699.200";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}