re = /(?!(^vlan6[0-9][0-9]\.199$))(^vlan6[0-9][0-9]\.[1-2][0-9][0-9]$)/m
str = 'vlan699.194
vlan699.199
vlan699.1993
vlan699.19
vlan699.200'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end