import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x) # x- modifiers to add comments in regex\n"
+ "#. #any character, except newline\n"
+ "\\s. #only space and newline characters\n"
+ "#\\w+ #Word quantifiers to match 1 or more words";
final String string = "This is a sample sentence\n"
+ "any thing other than new line character, includs number.... 1234567890";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}