re = /(?x) # x- modifiers to add comments in regex
#. #any character, except newline
\s. #only space and newline characters
#\w+ #Word quantifiers to match 1 or more words/m
str = 'This is a sample sentence
any thing other than new line character, includs number.... 1234567890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end