const regex = /(?x) # x- modifiers to add comments in regex
#. #any character, except newline
\s. #only space and newline characters
#\w+ #Word quantifiers to match 1 or more words/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x) # x- modifiers to add comments in regex
#. #any character, except newline
\\s. #only space and newline characters
#\\w+ #Word quantifiers to match 1 or more words', 'gm')
const str = `This is a sample sentence
any thing other than new line character, includs number.... 1234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}