using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"System\.out\.println\(\""[^\"":]*\s(?:job|jb?c)\s[^\"":]*:[^\""]*\""[^)]*\);";
string input = @"System.out.println(""my job code is: "" var.jobcode);
System.out.println(""my jc is: "" var.jc);
System.out.println(""my jbc is: "" var.jbc);
System.out.println (""component printout: item""); System.out.println (""); <td style=""word-break: break-all;word-wrap:break-word;font-size:12px;"" class=""FONTSTYLE"" align=""left"">Job Codes</td><td style=""word-break: break-all;word-wrap:break-word;font-size:12px;"" class=""FONTSTYLE"" align=""left"">
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}